jsp页面如何在ie浏览器加载的时候强制使用兼容性模式

2017-01-09 - 295 Words - 1,363 Views - 0 Goods - Nothing

现行ie版本实在太多,就算ie6不计,还有ie7,8,9,而且每个版本的兼容性差别都很大,对于架构和开发都是很头大的问题。

可以在head中放一段meta标签,指定ie使用某一版本模式进行浏览。比如:

指定浏览器使用ie7模式,当然了,浏览器必须是ie8及以上版本才支持,ie6不会支持以ie7模式浏览的,而且这个功能貌似也只有ie8及以上版本支持,地址栏中的兼容性视图按钮消失,普通终端用户不能修改兼容性设置,但是可以使用通过开发人员工具进行兼容性视图切换。同理:

转载请注明原文链接:首页 -> 技术交流 -> 前端开发 -> jsp页面如何在ie浏览器加载的时候强制使用兼容性模式
  • 支付宝打赏
  • 微信打赏

China.BeiJing

如果说人生是自我编写的程序,那么青春就是其中意味深长的代码